Gzipped only when compression set to true?

Jul 5, 2010 at 11:05 PM

Hi

What I did is this I have some plugins from jquery that are already minified so I put compression = false on these as they are minified already and I must keep their license thing on the file.

I then had another resource pack with my only scripts that where not minified so I put compression = true.

I then did something like this

 

        <resourceSet name="Scripts" type="js">
            <resource path="~/Myscripts.js" />
            <resource path="~/NotMyscripts.js" />
        </resourceSet>

 

So my thinking was that this still would be gizpped just not minified(well myscripts would be). Yet I look at my combined file and it says encoding is utf-8 and not gzipped. So how can I gzip it and keep those license comments?

Coordinator
Jul 6, 2010 at 2:19 PM

Hi!  Here's how things work:

- The compression attribute tells Combres as to whether it should compress (gzip or deflate) the output, it has nothing to do with minification.

- If you want to control minification, you have to set the resource set or resource to an appropriate minifier.  For example, if you want to turn off minification, you should set minifier=off.

If this doesn't answer or help address the issue, please post the full XML segment of the resource set in question (with compression and minification settings) and let me know what your goal is.