Dependency conflict w fasterflect

Feb 24, 2011 at 10:28 AM

Hi!

We got Combres 2.1 referenced. It uses fasterflect v 2.0.3732.24338. Now I needed fasterflect for my own reflection code. And installed it with NuGet, I got fasterflect v 2.0.1.0. Now I got a dependency fonflict:  No way to resolve conflict between "Fasterflect, Version=2.0.3732.24338, Culture=neutral, PublicKeyToken=d3b50d974897f4b5" and "Fasterflect, Version=2.0.1.0, Culture=neutral, PublicKeyToken=a64e1179c81b1e25"

I can download Combres and recompile it with 2.0.1.0.. but what is the best way of handling this?

 

 

Feb 24, 2011 at 12:07 PM

If I had that problem would do just that.
Another method could be adding "assembly binding" xml tag to web config (acctually exist for this purpose.),
or just use the old fasterflect version.